Michael_Giagnocavo

Anyone else seeing this

https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx FeedbackID=278291

In a workflow project, I can only use C# 2.0 features, not C# 3.0. Using any new features results in the same compiler error as if I was using the C# 2 compiler.

Brings a bit of a grinding halt to developing any code or activites in WF Orcas Sad.

-Michael



Re: Windows Workflow Foundation Orcas Beta 1: Wrong (old) compiler being used in Workflow C# projects

Roman Kiss

Michael,

- go to the project properties and change the Target Framework for .Net Framework 3.5

Thanks

Roman






Re: Windows Workflow Foundation Orcas Beta 1: Wrong (old) compiler being used in Workflow C# projects

Michael_Giagnocavo

Already set Smile.

I tried flipping it back and forth. Even the csproj file as ToolsVersion and TargetFrameworkVersion set to 3.5.

Hack for now is just copying the C# 3 compiler over the C# 2 compiler...





Re: Windows Workflow Foundation Orcas Beta 1: Wrong (old) compiler being used in Workflow C# projects

LorenzP

This is a known issue and will be fixed in time for RTM. Thank you for taking the time to let us know about it.




Re: Windows Workflow Foundation Orcas Beta 1: Wrong (old) compiler being used in Workflow C# projects

Michael_Giagnocavo

Besides overwriting the C# 2 compiler, is there any workaround that we can do with Beta 1 This is a pretty big blocking issue for us...

Thanks,

-Michael