Dam's

Hello,

We have developped an application using Visual Studio 2003 and Crystal Report embeded.

It properly works on Windows XP SP2 and some computers with Windows Vista.

But we encounter some trouble with some computer with Vista. When the application is running, it's not possible to open the viewer to display our reports. An error is raised, and the application ask to Quit or Continue.

I don't understand why it is working for some computers and it fails for others one.

Could you please help me Is there something particular to do

Thank you in advance for your help.

d.



Re: General Windows Vista Development Issues Visual Studio 2003, Crystal Report Embeded and Windows Vista

GreggD

We too are in the same situation. Everything works great in the app until attempting to run a report, and we get the keycodeV2.dll error. Manually registering the DLL, which is there, did not work, nor did uninstall/reinstall. Anyone have anything that can help DFiaux and I

GreggD




Re: General Windows Vista Development Issues Visual Studio 2003, Crystal Report Embeded and Windows Vista

Paolo_ituk

I had the same problem after installing my application onto a Windows Vista machine (with UAC switched off).

I eventually got it to work by manually registering both keycodeV2.dll and crqe.dll.

Although both files are contained in the Crystal Reports merge modules that are included in the installation package (MSI) it would appear that on Vista machines these files are not being registered during installation.