Darko Jovisic

Hi!

I'm using Orcas Beta1 VPC I downloaded from Microsoft site. I installed Acropolis, but when starting VS it says that there is a package load failure. I ignored this error and tried creating Notepad sample, but when the wizard finishes exception is thrown ('Class' attribute doesn't exist in XML Namespace...). I cannot copy the exception details from that window. If I click OK for the exception I can see that in the XAML code it says that it cannot create instance of the DocumentManager Anyone encountered this error and is there a workaround

Tnx,

Darko



Re: Acropolis package load failure

Benjamin Wulfe - MS

Which package did it say it failed to load




Re: Acropolis package load failure

Darko Jovisic

Package "Acropolis".



Re: Acropolis package load failure

burc sahinoglu

I have the same exact problem within the same environment.



Re: Acropolis package load failure

Benjamin Wulfe - MS

Only thing I can think of is that the Acropolis install had an error.

We will do some testing on this end. To try and fix this, can you uninstall Acropolis and reinstall. When you reinstall, can you run the setup program as admin






Re: Acropolis package load failure

Benjamin Wulfe - MS

Another thing you can do to really help us is to:

1. Start VS (hit "No" for disabling the package so you get the error each time. If you already hit yes, reset this setting by running "devenv /resetskippkgs" from the command line

2. In VS, open "devenv.exe" as a project, turn on all first chance exceptions and hit F5. There should be an exception that occurs when the Acropolis package attempts to load. It will either be a loadkey problem or it will be a missing managed reference.

Also, please post the url to the VPC of VS you used to install on.






Re: Acropolis package load failure

burc sahinoglu

I believe I downloaded from here: http://www.microsoft.com/downloads/details.aspx familyid=B533619A-0008-4DD6-9ED1-47D482683C78&displaylang=en#filelist

I tried uninstalling/reinstalling no difference

Here is what happens when I start devenv.exe within VS (with the exceptions at the bottom)

Hope this will help,

===========================================================================:

'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe'
'devenv.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\custsat.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\user32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\ole32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\oleaut32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\mscoree.dll'
'devenv.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.20209.4864_x-ww_4b050153\msvcr90.dll', Symbols loaded.
'devenv.exe': Loaded 'C:\WINDOWS\system32\shell32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.3790.2778_x-ww_A8F04F11\comctl32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\xpsp2res.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\msenv.dll'
'devenv.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.20209.4864_x-ww_aba4eec7\ATL90.dll', Symbols loaded.
'devenv.exe': Loaded 'C:\WINDOWS\system32\uxtheme.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\version.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\sxs.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\1033\msenvui.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\1033\msenvmui.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\system32\userenv.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\clbcatq.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\comres.dll'
'devenv.exe': Loaded 'C:\Program Files\Common Files\Microsoft Shared\VS7Debug\msdbg2.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\VC\vcpackages\1033\vcpkgui.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\VC\vcpackages\1033\VCProjectUI.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\urlmon.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies\1033\Microsoft.VisualStudio.TeamFoundation.VersionControlUI.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\VS SCC\Tfsproviderstub.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\VS SCC\1033\Tfsproviderstubui.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\system32\rsaenh.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\psapi.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\1033\Microsoft.Workflow.VSDesignerUI.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll'
'devenv.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.42_x-ww_0de06acd\msvcr80.dll', Symbols loaded.
'devenv.exe': Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Culture.dll'
'devenv.exe': Unloaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Culture.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\mscorlib\1b739bf5da2f302bad52a9496530e639\mscorlib.ni.dll'
'devenv.exe': Loaded 'ImageAtBase0x50990000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x50990000'
'devenv.exe': Loaded 'ImageAtBase0x631b0000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x631b0000'
'devenv.exe': Loaded 'ImageAtBase0x6b900000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b900000'
'devenv.exe': Loaded 'ImageAtBase0x6b920000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b920000'
'devenv.exe': Loaded 'ImageAtBase0x6b900000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b900000'
'devenv.exe': Loaded 'ImageAtBase0x6b870000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b870000'
'devenv.exe': Loaded 'ImageAtBase0x50b80000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x50b80000'
'devenv.exe': Loaded 'ImageAtBase0x50bb0000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x50bb0000'
'devenv.exe': Loaded 'ImageAtBase0x6c120000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6c120000'
'devenv.exe': Loaded 'ImageAtBase0x6bbe0000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6bbe0000'
'devenv.exe': Loaded 'ImageAtBase0x6bdd0000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6bdd0000'
'devenv.exe': Loaded 'ImageAtBase0x51b90000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x51b90000'
'devenv.exe': Loaded 'ImageAtBase0x6b850000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b850000'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.CommonIDE\9.0.0.0__b03f5f7f11d50a3a\microsoft.visualstudio.commonide.dll'
'devenv.exe': Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorjit.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\System\a345f630970b49d18ea35968f7aa35ab\System.ni.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\System.Drawing\60b0c8bcb61689046fd61c4fa5cc4a7c\System.Drawing.ni.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\System.Windows.Forms\9136699b5812ba28951d54d39d53c29a\System.Windows.Forms.ni.dll'
'devenv.exe': Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorsec.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\wintrust.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\crypt32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\msasn1.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\imagehlp.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\riched20.dll'
'devenv.exe': Unloaded 'C:\WINDOWS\system32\riched20.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\secur32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\netapi32.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\cryptnet.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\sensapi.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\wldap32.dll'
'devenv.exe': Loaded 'ImageAtBase0x6b970000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b970000'
'devenv.exe': Loaded 'ImageAtBase0x6b820000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b820000'
'devenv.exe': Loaded 'ImageAtBase0x51c40000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x51c40000'
'devenv.exe': Loaded 'ImageAtBase0x630e0000'
'devenv.exe': Unloaded 'ImageAtBase0x630e0000'
'devenv.exe': Loaded 'ImageAtBase0x6b870000', No symbols loaded.
'devenv.exe': Unloaded 'ImageAtBase0x6b870000'
'devenv.exe': Loaded 'ImageAtBase0x6b900000'
'devenv.exe': Unloaded 'ImageAtBase0x6b900000'
'devenv.exe': Loaded 'ImageAtBase0x59560000'
'devenv.exe': Unloaded 'ImageAtBase0x59560000'
'devenv.exe': Loaded 'ImageAtBase0x6c000000'
'devenv.exe': Unloaded 'ImageAtBase0x6c000000'
'devenv.exe': Loaded 'ImageAtBase0x6b850000'
'devenv.exe': Unloaded 'ImageAtBase0x6b850000'
'devenv.exe': Loaded 'ImageAtBase0x50bc0000'
'devenv.exe': Unloaded 'ImageAtBase0x50bc0000'
'devenv.exe': Loaded 'ImageAtBase0x51d00000'
'devenv.exe': Unloaded 'ImageAtBase0x51d00000'
'devenv.exe': Loaded 'ImageAtBase0x6b950000'
'devenv.exe': Unloaded 'ImageAtBase0x6b950000'
'devenv.exe': Loaded 'ImageAtBase0x566f0000'
'devenv.exe': Unloaded 'ImageAtBase0x566f0000'
'devenv.exe': Loaded 'ImageAtBase0x631b0000'
'devenv.exe': Unloaded 'ImageAtBase0x631b0000'
'devenv.exe': Loaded 'ImageAtBase0x6c090000'
'devenv.exe': Unloaded 'ImageAtBase0x6c090000'
'devenv.exe': Loaded 'ImageAtBase0x6c120000'
'devenv.exe': Unloaded 'ImageAtBase0x6c120000'
'devenv.exe': Loaded 'ImageAtBase0x6bd60000'
'devenv.exe': Unloaded 'ImageAtBase0x6bd60000'
'devenv.exe': Loaded 'ImageAtBase0x6b900000'
'devenv.exe': Unloaded 'ImageAtBase0x6b900000'
'devenv.exe': Loaded 'ImageAtBase0x51b90000'
'devenv.exe': Unloaded 'ImageAtBase0x51b90000'
'devenv.exe': Loaded 'ImageAtBase0x6b7f0000'
'devenv.exe': Unloaded 'ImageAtBase0x6b7f0000'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.Shell.9.0\2.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.Shell.9.0.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.Shell.Interop\7.1.40304.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.Shell.Interop.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.OLE.Interop\7.1.40304.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.OLE.Interop.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.Shell.Interop.8.0\8.0.0.0__b03f5f7f11d50a3a\microsoft.visualstudio.shell.interop.8.0.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.TextManager.Interop\7.1.40304.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.TextManager.Interop.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Workflow.ComponentModel\3.0.0.0__31bf3856ad364e35\System.Workflow.ComponentModel.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.Debugger.Interop\8.0.1.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.Debugger.Interop.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\EnvDTE\50517523fd6d67ea6e7c6a4c86ad722c\EnvDTE.ni.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC\Microsoft.VisualStudio.TextManager.Interop.8.0\8.0.0.0__b03f5f7f11d50a3a\microsoft.visualstudio.textmanager.interop.8.0.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'ImageAtBase0x6c210000'
'devenv.exe': Unloaded 'ImageAtBase0x6c210000'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\System.Xml\2316d060151419c089044ef741b8b006\System.Xml.ni.dll'
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.MSXML\8.0.0.0__b03f5f7f11d50a3a\microsoft.msxml.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\Packages\Debugger\vsdebug.dll'
'devenv.exe': Loaded 'C:\WINDOWS\system32\msimg32.dll'
'devenv.exe': Loaded 'C:\Program Files\Microsoft Visual Studio 9.0\Common7\Packages\Debugger\1033\vsdebugui.dll', Binary was not built with debug information.
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: EEMessageException at memory location 0x0012f134..
First-chance exception at 0x77e55e02 in devenv.exe: 0xE0434F4D: 0xe0434f4d.
'devenv.exe': Loaded 'C:\Program Files\Microsoft Acropolis CTP1\1033\Microsoft.VisualStudio.AcropolisUI.dll', Binary was not built with debug information.
'devenv.exe': Loaded 'C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualStudio.Shell\2.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualStudio.Shell.dll'
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: EEFileLoadException at memory location 0x0012d9cc..
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: [rethrow] at memory location 0x00000000..
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: [rethrow] at memory location 0x00000000..
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: [rethrow] at memory location 0x00000000..
First-chance exception at 0x77e55e02 in devenv.exe: 0xE0434F4D: 0xe0434f4d.
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: [rethrow] at memory location 0x00000000..
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: [rethrow] at memory location 0x00000000..
First-chance exception at 0x77e55e02 in devenv.exe: Microsoft C++ exception: EEException at memory location 0x0012f0e8..
First-chance exception at 0x77e55e02 in devenv.exe: 0xE0434F4D: 0xe0434f4d.
Package 'Acropolis' failed to load.
The thread 'Win32 Thread' (0x4d8) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0xdf0) has exited with code 0 (0x0).
The thread 'Win32 Thread' (0xce8) has exited with code 0 (0x0).






Re: Acropolis package load failure

Dennis Dietrich - MSFT

Burc, the link you posted points to the Orcas March CTP. However, Acropolis requires Orcas Beta 1 (http://www.microsoft.com/downloads/details.aspx FamilyId=36B6609E-6F3D-40F4-8C7D-AD111679D8DC&displaylang=en). Darko, I'm not sure what happened in your case but I just did a test run with the Orcas Beta 1 VM and the Acropolis July CTP and it worked fine. I'd like to ask you to give that a try and let us know if it still doesn't work for you.

Best regards

Dennis "D.C." Dietrich

This posting is provided "AS IS" with no warranties, and confers no rights.