J.J. Alan


Hi, I'm J.J. Alan!
Some months ago, I've build a bot on Java Incesoft SDK, named Doriana { chattami@doriana82.it }.
I've provisioned it following the procedure of botprovision@hotmail.com, and everything was fine!

Few days ago, most of people that trying to chat with Doriana, get back their messages with the error: "The following message could not be delivered to all recipients". By the way, some users, can still chat with it.

The bot is still online for all the people.
The ones who can not chat with Doriana, doesn't see her name in the buddy list, just her email.

I don't know how to resolve this problem, and how to make my bot works again!!!
I've reboot either bot and contact too, but it was helpless.
I've tryied to provision it again, but botprovision@hotmail.com says that i've already compiled the form.
I've tryied to send it to the Gallery too. With no results!



Anyone else has this problem
Why does this appenend There's a time-limit for BOT provision
Or I lost it for some other reason
What shall I do

Please, help me!
By J.J. Alan.



Re: Lost BOT provision?! Help!

Jeroen Bransen - J-Thread


If the bot appears online for all users, the bot provisioning worked, so no worry about that.
Are you sure the bot is online If only the e-mail address appears but not the name, it looks like the bot isn't really online. That it appears to be online on your list is only because it's a bot, and bots always appear online. So, to solve thi, I think it's best to check the server where you host the bot to see if it really is signed in, and if not why not.





Re: Lost BOT provision?! Help!

J.J. Alan

Hi Jeroen! Thanks for your reply!
I've checked, and the server where I host my bot is online and completely working with some users.
When server is offline, my bot says "Sorry, service provider offline!".
This time, messages from most of the buddys just couldn't be sent (they come back).
So I think the deal is not the program!

Some months ago, I asked Microsoft to provisioned my Bot, and I had to wait long time before they could accomplished my request.
In those time, just few people could chat with her. The others, can't even send their messages!
Just like ...now!
This is the reason why I think it's a provision problem!

Now, my bot was approved in the Microsoft Gallery, but the problem, still remain.
Only few users could chat with the bot. The others, can't even send their messages!
By the way, the server is online and working property!



If someone know what is going on... please, help me!
By J.J. Alan






Re: Lost BOT provision?! Help!

Jason Francis 每 MSFT

Hi J.J. Alan,

I've just added Doriana to my contact list and the Bot seems to be working just fine. From the limited italian I know, it seems to be responding to queries.

It might have been an intermittent problem with your servers. A provisioned bot will appear online, even if it's servers aren't responding to queries, hence "The following message could not be delivered to all recipients."

I would double check your logs to see if the servers went down.

In the meantime, I will contact Messenger Ops to see if the ID was provisioned correctly.

Regards,

Jason





Re: Lost BOT provision?! Help!

J.J. Alan

Hi Jason! Thanks for the help!
I'm moving out, so it's really possibile that sometimes server's down... in those cases, Doriana will reply with "Sorry, service provider offline" that is the standard message of Incesoft Platform.
Don't care too much about that!

The real problem, is that sometimes { like now! } most of the users cannot send messages to her. They don't receive any reply from BOT or from Incesoft Server. Just "The following message could not be delivered to all recipients.".
I know for sure that during this periods my server was UP! In fact, some users could still chat with her, but not everyones!

And i really don't know why...
Mysteriously, Doriana turns up for every buddys in the list some days ago.
Now, she got this problem again!

Sorry for my bad English... thus my name, I'm Italian! Big Smile

Ps. What is Messenger Ops I never hear about that! Smile

Thanks again,
J.J. Alan!




Re: Lost BOT provision?! Help!

Jason Francis 每 MSFT

I've confirmed with Ops (Messenger Operations) that the Doriana LIVE ID was provisioned correctly on May 1st, 2007.

Have you contacted Incesoft regarding this issue

Jason