TGriff


I'm having a problem with the IFrame WebAuthControl on Firefox pages. In every other browser(Safari for Windows, IE, Opera) once a windows live user is signed in, the IFrame auth control message switches to sign-out appropriatly. In Firefox/2.0.0.8 the IFrame message is always Sign-In even after logging in with a windows Live ID. Anyone else come across this Is Firefox not sending the correct POST/GET params the IFrame control is expecting

I'm currently accepting cookies until they expire in my privacy settings for Firefox. Any help with this would be greatly appreciated.



Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff


Anyone have an answer for this. I'm not asking for Firefox support, although that'd be wonderful, but hey if it works in the other 3 browsers and not Firefox, I'll proceeed to release the Live ID capabilities for users of those browsers it works for. A simple yes/no would do.






Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff

My implementation for Windows Live ID has been released. view it here http://www.msg-time.com

This works in IE, Opera, and Safari. Just asking again if anyone would know why the sign-in link would not be able to display in Firefox 2.0. I will make this visible for firefox users for the time being until I get some remedy on this...but if not I guess they'll have to miss out on this wonderful addition. Thanks for any help with this.





Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff

Final Bump...

I've disabled the Windows Live ID sign-in for Firefox. If someone decides to provide assitance on here, I can provide a test url that is accessible in firefox. Hard to imagine i'm the only one trying to use this with Firefox, but hopefully someone could share on their Firefox success or lack thereof when implementing Windows Live ID.




Re: WebAuthControl IFrame never displays Sign-Out in Firefox

Jorgen Thelin - MSFT

I've tried this myself using Firefox v2.0.0.9 and the Sign-in / Sign-out link showed up as expected.

Maybe you could send your test URL so others can look at it





Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff

That's good to know.

here's my test link because I'm still seeing the behavior on my end.

http://www.msg-time.com/livetest.php

could you provide details of your privacy, security, and content settings for firefox. I'll try using v2.0.0.9 as well. Maybe just do a clean default install and see what happens. Thanks for the help ans response.




Re: WebAuthControl IFrame never displays Sign-Out in Firefox

Jorgen Thelin - MSFT

I've tried Firefox 2.0.0.9 against the livetest.php URL, and it's definitely working OK for me.

I login, then see the Sign-out link as expected.

Naturally I'm running on Windows Vista, but I'm just using the standard settings out-of-the-box for Firefox - no special security, privacy or content settings - just the standard default installation.





Re: WebAuthControl IFrame never displays Sign-Out in Firefox

Alex Media

I have to agree with Jorgen, everything here works too... Firefox 2.0.0.9 (nl-NL) on Windows Vista (English), using the default security settings. Have you tried clearing the buffer and cookies





Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff

That works for me. I'm on XP. And obviously it is just me so I feel comfortable now. Thanks for helping guys.




Re: WebAuthControl IFrame never displays Sign-Out in Firefox

TGriff

Found why my cookie state wasn't being saved with IFrames. I was testing a facebook component for my app and was having the same sign-in and out issues. Checking my about:config in firefox I had:

network.cookie.cookieBehavior = 1
privacy.item.cookies = true

changing these to

network.cookie.cookieBehavior = 0
privacy.item.cookies = false

Did the trick for me. That was so nerve racking...