AHO11


Hey!

I am really interested in having Windows Live ID part of my website. I have read almost all the information on it and im a little stuck.

I host my website with a company which uses cPanel, so there is the only place i can change settings ect.

I have tryed uploading the sample but all i get is this:

"Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/micrrco/public_html/members/userdb.php on line 10"

Can anyone please tell me what i am doing wrong and maybe give me some simple steps on what i can do to get this started on my website.

All help is appreciated!





Re: Help starting up

Alex Media


Are you sure your host is running PHP 5 WL ID Web Authentication will not work with PHP 4 and lower...






Re: Help starting up

AHO11

Well i have just had a look, and my host says "PHP 4+5", so i think thats a yes.







Re: Help starting up

Alex Media

Mm, maybe there's a switch to php5 somewhere, or you'll have to give the Live-files an other extension, maybe .php5

Try this:

Create a file called phpinfo.php, with this as contents:

< php

phpinfo();

>

Browse to that file and look at what it says about the PHP-version. Then rename it to phpinfo.php5, and look at that file...





Re: Help starting up

AHO11

Ok thanks. That problem is now fixed. It was set at PHP4 and i had to change it to PHP5.

My next question is using the Windows Live ID, can i actually create something like a members area, where only people who have signed in can view some pages






Re: Help starting up

Alex Media

Yes, you can! Smile

If you look at the sample given, you will see that it has such a "feature" built-in. You can use the code provided there to check if users are authenticated or not Smile





Re: Help starting up

AHO11

Ok thanks, i will look that up later.

But before i continue, i think there is a problem with my sample, but im not sure. Even when im logged in it says "

This application does not know who you are! Click the Sign in link above." even when i am signed in. It never askes me for my name which i think i have read somewhere it should do.






Re: Help starting up

Alex Media

Hmm, that would probably mean that something is wrong with the authentication handler. If you're logged in successfully, a cookie should be placed with your token (if I remember correctly, that is), does such a cookie exist