Ewgene Bumarin


Hi, everyone!

Now implementing a search for my web site using The Live Search Web Service API but cannot obtain an Application ID. When pointing to http://search.msn.com/developer (following the instructions at e.g. http://msdn2.microsoft.com/en-us/library/bb266187.aspx) I see only the Live Search information page with the message "The requested page could not be found" but nothing like Create and Manage Application IDs... I would think this link is out-of-date but I cannot find any new one. Appreciate any clues. Am I doing anything wrong or the service is not available or it's an error with my network etc Does anyone else face the same problem

Thanks everyone in advance!

With respect.




Re: Cannot obtain an Application ID

Yu-Ting Kuo - MSFT


can you try it again i just clicked the link you had above and it worked (it is a correct link).

i will close this for now and if you continue to have issues accessing appid site please let me know.

thanks.






Re: Cannot obtain an Application ID

immenly

I too can not access the link http://search.msn.com/developer.There are restrictions for Russia






Re: Cannot obtain an Application ID

immenly

I have no link opens http://search.msn.com/developer.There are restrictions for Russia






Re: Cannot obtain an Application ID

Ewgene Bumarin

Still have the same problem.

Let me give more details. The link works indeed. When I click it I see no http 404 response page which my browser typically generates if a resource is not found. I see the Life Search results page. But there is nothing about "Manage app. IDs" on it. The only informative message is "The requested page could not be found" which is in Russian and some common links (e.g. Live home).

Is it a right suggestion this service is restricted for some regions or IPs The service was promoted by Microsoft at ".Net Developer Day" held letely in Moscow so hope the suggestion is wrong. Much obvious the problem is within the service itself that`s why I`m posting at this forum with a phantom hope to hear the opinion of the qualified staff.





Re: Cannot obtain an Application ID

Yu-Ting Kuo - MSFT

sorry you were having trouble accessing appid creation/management tool page. i will need to check with our team to see what might have happened. i will circle back as soon as i have more info.

in the meantime - can you try http://search.msn.com/developer/appids.aspx and see if it takes you there (you will be asked to login with a windows live id).

thanks.





Re: Cannot obtain an Application ID

Ewgene Bumarin

Thank you for your care, Yu-Ting Kuo. Unfortunately I see the same screen at http://search.msn.com/developer/appids.aspx as it was at http://search.msn.com/developer as I click this link directly .

Russian Community members advised me to try an anonymous proxy (if you familiar with Russian you can see posts at http://forums.microsoft.com/TechNet-RU/ShowPost.aspx PostID=2276751&SiteID=40&mode=1) and that solution worked pretty well. The only thing I can suggest after this is: there is some kind of IP blocking for this service. Sad to realize...





Re: Cannot obtain an Application ID

Yu-Ting Kuo - MSFT

try this: http://search.msn.com/developer mkt=en-us





Re: Cannot obtain an Application ID

Ewgene Bumarin

Yes, the last one works perfectly!

Thank you very much for your help!





Re: Cannot obtain an Application ID

PaulTan808

I tried clicking on this link to get an App ID for the Live Search API, it shows the page but if I try clicking on the get App ID link but it only shows me a blank page.

Thanks,

Paul






Re: Cannot obtain an Application ID

Steve2266

I'm also not able to get an Application ID. I log in and then it just shows a blank page.




Re: Cannot obtain an Application ID

Adrian Herscu

Using the URL above I can get an Application ID; however, when trying to invoke the service using

<soapenv:Envelope
xmlnsTongue Tiedoapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:q0="http://schemas.microsoft.com/MSNSearch/2005/09/fex"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
<q0Tongue Tiedearch>
<q0:Request>
<q0:AppID>DB1209946CAC2D7D0A7731FCB31D809F4A69BA2B</q0:AppID>
<q0:Query>adrian</q0:Query>
<q0:CultureInfo>en-US</q0:CultureInfo>
<q0Tongue TiedafeSearch>Moderate</q0Tongue TiedafeSearch>
<q0:Flags />
<q0:Requests />
</q0:Request>
</q0Tongue Tiedearch>
</soapenv:Body>
</soapenv:Envelope>

I get this


<soapenv:Envelope
xmlnsTongue Tiedoapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
<soapenv:Fault>
<faultcode>soapenv:Client</faultcode>
<faultstring>Client Error</faultstring>
<detail>Invalid value for AppID in request</detail>
</soapenv:Fault>
</soapenv:Body>
</soapenv:Envelope>


Any suggestions


Adrian.

PS: BTW, the forum editor sucks!!!





Re: Cannot obtain an Application ID

MrZoom

I have the same problem. How can I get an Application ID