Serge Calderara

dear all,

I have install my WCF service under WAS on MACHINE1 and on MACHINE2

I have verify that on both machine I can access to the service with the browser.

Then I have a small client application whcih connect to this WCF service

First of all if I run the client application locally on each machine, I can access correctly to the local service

So it means that both local configuration works fine.

Then if I run my client application on MACHINE1 and want to access the WCF service under WAS on MACHINE2 with adress endpoint net.tcp://machine2/myService/service.svc I get an error message that remote machine did not answer within predifne time out.

Both machine are located on the same network, no firewall between and authentification mode has been set as Windows.

my config fiel content from server side is as follow :

<system.serviceModel>
<bindings>
<netTcpBinding>
<binding name="netTcpBinding_IAlarm">
<security mode="Transport">
<transport clientCredentialType="Windows" />

</security>
</binding>
</netTcpBinding>

</bindings>


<services>
<!-- Definition of the Alarm object service-->
<service name="Maillefer.Nomos.Plateform.EventSys.AlarmHistory" behaviorConfiguration="Maillefer.Nomos.Plateform.Service.Console.Behavior">
<endpoint address="" contract="Maillefer.Nomos.Types.IAlarmHistory" binding="netTcpBinding" />

<!-- the mex endpoint is exposed at http://localhost/AlarmService/service.svc/mex -->
<endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange" />

</service>

</services>

<!-- Definition of services behaviour based on behaviorConfiguration from <Service> entry-->
<behaviors>
<serviceBehaviors>
<behavior name="Maillefer.Nomos.Plateform.Service.Console.Behavior">
<serviceMetadata httpGetEnabled="true" />
<serviceDebug includeExceptionDetailInFaults="true" />
</behavior>
</serviceBehaviors>
</behaviors>
</system.serviceModel>

What did I miss in order to connect correcty

is tehre any sertting to check under IIS7 for my service I have enable Windows autentication in IIS but no luck

thnaks for help

regards

serge




Re: Windows Communication Foundation (Indigo) Access to WCF Service on a remote machine ??

John Lambert - MSFT

Does it work if security mode is "None"

Also, are you sure that there is no firewall enabled Has the Windows firewall been disabled, too






Re: Windows Communication Foundation (Indigo) Access to WCF Service on a remote machine ??

Serge Calderara

I will cross check that on monday john as its week end now :-)

which god week end to you by the way..

serge