msdobrescu2

Hello,

I tried to make a windows service that hosts a WCF service.
Naturally, I've tried the sample first.
It crushes raising an error:

System.ServiceModel:Incorrect function at System.ServiceModel.Channels.SharedHttpTransportManager.OnOpen()
at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
at System.ServiceModel.Channels.HttpChannelListener.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.DatagramChannelDemuxer`2.OnOuterListenerOpen(ChannelDemuxerFilter filter, IChannelListener listener, TimeSpan timeout)
at System.ServiceModel.Channels.SingletonChannelListener`3.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.NegotiationTokenAuthenticator`1.OnOpen(TimeSpan timeout)
at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.SecurityUtils.OpenCommunicationObject(ICommunicationObject obj, TimeSpan timeout)
at System.ServiceModel.Security.SecurityProtocolFactory.Open(String propertyName, Boolean requiredForForwardDirection, SecurityTokenAuthenticator authenticator, TimeSpan timeout)
at System.ServiceModel.Security.SymmetricSecurityProtocolFactory.OnOpen(TimeSpan timeout)
at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.SecurityListenerSettingsLifetimeManager.Open(TimeSpan timeout)
at System.ServiceModel.Channels.SecurityChannelListener`1.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.SecuritySessionSecurityTokenAuthenticator.OnOpen(TimeSpan timeout)
at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.SecurityUtils.OpenCommunicationObject(ICommunicationObject obj, TimeSpan timeout)
at System.ServiceModel.Security.SecuritySessionServerSettings.OnOpen(TimeSpan timeout)
at System.ServiceModel.Security.WrapperSecurityCommunicationObject.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Security.SecurityListenerSettingsLifetimeManager.Open(TimeSpan timeout)
at System.ServiceModel.Channels.SecurityChannelListener`1.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)

On Windows XP 32 works fine the same code.

Any idea

Mike


Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

I am in the middle of building one 64bit repro machine for this issue. could you provide more information on which sample test did you try, and how I can repro it please



Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

I have taken the following sample:

ms-help://MS.MSSDK.1033/MS.NETFX30SDK.1033/WCF_samples/local/sampleexecutables/TechnologySamples/Basic/Service/Hosting/WindowsService.zip

Which can be found by installing the MicrosoftR WindowsR Software Development Kit for Windows Vista(TM) and .NET Framework 3.0 Runtime Components (build 6.0.6000.0.0), browse the accompanying documentation as follows:

.Net Framework Development
- Windows Communication Foundation
- Windows Communication Foundation
- Samples
+ WCF Samples
+ Windows Communication Foundation Samples
+ Windows Communication Foundation Technology Samples
+ Basic Windows Communication Foundation Technology Samples
+ Service Samples
+ Service Hosting Samples
+ Windows Service Host
+ Download Sample

Note: "-" marks Microsoft Windows SDK Documentation Menu
"+" marks link in documentation page

Good luck!

Mike




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

Hello,

Was my information useful to you
I couldn't make it work.
Is this a real bug
Any help is appreciated!
Thanks.

Mike




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

Sorry, my first attempt to build a repro machine failed with a dead partition I can't even boot from. To be safe I am now requesting a repro machine build by the lab, it might take a day or so before I can get it. I will update on my findings once I can try the repro.

On the side note, the link you have provided doesn't work for me, could you tell me where you downloaded that sample package please

Thanks.





Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

Dear Sir,

That's the link you have to go to after you follow the steps described:

1. Install the MicrosoftR WindowsR Software Development Kit for Windows Vista(TM) and .NET Framework 3.0 Runtime Components (build 6.0.6000.0.0)
2. Browse the accompanying documentation as follows:

.Net Framework Development
- Windows Communication Foundation
- Windows Communication Foundation
- Samples
+ WCF Samples
+ Windows Communication Foundation Samples
+ Windows Communication Foundation Technology Samples
+ Basic Windows Communication Foundation Technology Samples
+ Service Samples
+ Service Hosting Samples
+ Windows Service Host
+ Download Sample

Note: "-" marks Microsoft Windows SDK Documentation Menu
"+" marks link in documentation page

3. Eventually, 'Download Sample' leads you to the link:
ms-help://MS.MSSDK.1033/MS.NETFX30SDK.1033/WCF_samples/local/sampleexecutables/TechnologySamples/Basic/Service/Hosting/WindowsService.zip,
which is on local documentation installed by
MicrosoftR WindowsR Software Development Kit for Windows Vista(TM) (at step 1). This is local, not on the web.

On the web, as alternative, go to
Windows Communication Foundation Samples --> Windows Communication Foundation Technology Samples --> Basic Windows Communication Foundation Technology Samples --> Service Samples --> Service Hosting Samples --> Windows Service Host --> Download sample.
This will download many WCF samples in one archive and you will find it - after extracting from the archive - on the following path:

WCF_Samples\TechnologySamples\Basic\Service\Hosting\WindowsService.

We might be delayed in communication by local hour (mine is GMT + 2).

I am eager to hear your news and do not hesitate to ask me any question!




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

Thanks for the additional information.  Could you provide the link to where you have downloaded the "MicrosoftR WindowsR Software Development Kit for Windows Vista(TM) and .NET Framework 3.0 Runtime Components (build 6.0.6000.0.0)" from as well   I want to make sure I have the same setup as your machine does.

Thanks.

---------------

NVM, I think I found it at http://www.microsoft.com/downloads/details.aspx FamilyId=C2B1E300-F358-4523-B479-F53D234CDCCF&displaylang=en

 





Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

I confirm,

You are on the right track.
BUT, I've downloaded the DVD Image, see on the bottom of the page in section 'Instructions'.
The direct link is: DVD ISO image.

Sorry for the delay, it was really late for me yesterday....




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

I am following the steps, but looks like the SetupCertTool.bat is not doing its job:

One-time setup procedure for WCF samples

7. Open a Visual Studio command window using an account with Administrator privileges. Run the Setupcerttool.bat file:

  • The FindPrivateKey tool is built.

  • A directory is created at %ProgramFiles%\ServiceModelSampleTools.

  • FindPrivateKey is copied to this directory.

I was only able to get an empty %ProgramFiles%\ServiceModelSampleTools folder with no FindPrivateKey tool built there. I had to manually build the tool and copy them over. Can you confirm the same behavior on your machine

Thanks.





Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

Okay, after I got everything setup, I build the WindowsService sample package on both client and server folder. I than run the following command:

Step1. Setup the service:

D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service>setup.bat
Microsoft (R) .NET Framework Installation utility Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.


Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\C
S\service\bin\service.exe assembly's progress.
The file is located at D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\serv
ice.InstallLog.
Installing assembly 'D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\servic
e.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\service.e
xe
logfile = D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\service.Instal
lLog
Installing service WCFWindowsServiceSample...
Service WCFWindowsServiceSample has been successfully installed.
Creating EventLog source WCFWindowsServiceSample in log Application...

The Install phase completed successfully, and the Commit phase is beginning.
See the contents of the log file for the D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\C
S\service\bin\service.exe assembly's progress.
The file is located at D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\serv
ice.InstallLog.
Committing assembly 'D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\servic
e.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\service.e
xe
logfile = D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\service\bin\service.Instal
lLog

The Commit phase completed successfully.

The transacted install has completed.
The WCFWindowsServiceSample service is starting.
The WCFWindowsServiceSample service was started successfully.

Step2. start the client:

D:\Documents and Settings\INDGAUNT\Desktop\WindowsService\CS\client\bin>client.exe
Add(100,15.99) = 115.99
Subtract(145,76.54) = 68.46
Multiply(9,81.25) = 731.25
Divide(22,7) = 3.14285714285714

Press <ENTER> to terminate client.

Basically, it is working fine on my repro machine, Please let me know if there is anything special you have done on your machine setup

Thanks.





Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

I have unzipped the exe file (WCF_Samples.exe, downloaded as described before), and there I have the batches:

WCF_Samples\TechnologySamples\Setup\CS

There I've successfully followed the steps:

7. Open a Visual Studio command window using an account with Administrator privileges. Run the Setupcerttool.bat file:

  • The FindPrivateKey tool is built.

  • A directory is created at %ProgramFiles%\ServiceModelSampleTools.

  • FindPrivateKey is copied to this directory.

But my sample is not meant for IIS.

My firewall allows the sample to get through.




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

First of all, I have Visual Studio Express.

Here is the log:
D:\WCF_Samples\TechnologySamples\Setup\CS>D:\WCF_Samples\TechnologySamples\Basic
\Service\Hosting\WindowsService\CS\service\setup.bat
Microsoft (R) .NET Framework Installation utility Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.


Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the D:\WCF_Samples\TechnologySamples\Setup\
CS\bin\service.exe assembly's progress.
The file is located at D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.Ins
tallLog.
Installing assembly 'D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe'.

Affected parameters are:
logtoconsole =
assemblypath = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe
logfile = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.InstallLog
Installing service WCFWindowsServiceSample...
Creating EventLog source WCFWindowsServiceSample in log Application...

An exception occurred during the Install phase.
System.ComponentModel.Win32Exception: The specified service already exists

The Rollback phase of the installation is beginning.
See the contents of the log file for the D:\WCF_Samples\TechnologySamples\Setup\
CS\bin\service.exe assembly's progress.
The file is located at D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.Ins
tallLog.
Rolling back assembly 'D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe
'.
Affected parameters are:
logtoconsole =
assemblypath = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe
logfile = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.InstallLog
Restoring event log to previous state for source WCFWindowsServiceSample.

The Rollback phase completed successfully.

The transacted install has completed.
The installation failed, and the rollback has been performed.
System error 3 has occurred.

The system cannot find the path specified.

D:\WCF_Samples\TechnologySamples\Setup\CS>


the service.InstallLog contains:

Installing assembly 'D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe
logfile = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.InstallLog
Installing service WCFWindowsServiceSample...
Creating EventLog source WCFWindowsServiceSample in log Application...
Rolling back assembly 'D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe'.
Affected parameters are:
logtoconsole =
assemblypath = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.exe
logfile = D:\WCF_Samples\TechnologySamples\Setup\CS\bin\service.InstallLog
Restoring event log to previous state for source WCFWindowsServiceSample.

The Event log message is:

The WCFWindowsServiceSample service failed to start due to the following error:
The system cannot find the path specified.


I have no clue on what's missing.






Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

Jeff Cao

Well, it should matter which Visual Studio version you are using. After you have extracted the sample zip package into client and server sub-folders, you do need to load up each project and build it first before you can run the setup.exe. Basically, when you build the projects, it will create the bin\debug\*.exe under each sub-folder. I am guessing that's the "path not found" error from setup.exe if you haven't done so before you trying to setup the service.

Please let me know if that is the case

Thanks.





Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

Hello,

I've tested and found some issues related to the service registering.
The @echo off prevented me to know the error : it was already registered.
I've cleaned up the installation, I've re-installed the service and it stops at starting phase.
The event log stays with the same message as I've mentioned in the beginning:

Application:
Service cannot be started. System.ServiceModel.CommunicationException: Incorrect function ---> System.Net.HttpListenerException: Incorrect function
at System.Net.HttpListener.AddAll()
at System.Net.HttpListener.Start()
at System.ServiceModel.Channels.SharedHttpTransportManager.OnOpen()
--- End of inner exception stack trace ---
at System.ServiceModel.Channels.SharedHttpTransportManager.OnOpen()
at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
at System.ServiceModel.Channels.HttpChannelListener.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.DatagramChannelDemuxer`2.OnOuterListenerOpen(ChannelDemuxerFilter filter, IChannelListener listener, TimeSpan timeout)
at System.ServiceModel.Channels.SingletonChannelListener`3.OnOpen(TimeSpan timeo...

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Now I have one more in the System log:

Unable to bind to the underlying transport for 0.0.0.0:8000. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine. The data field contains the error number.

The data field:

0000: 00 00 04 00 02 00 52 00 ......R.
0008: 00 00 00 00 9d 3a 00 c0 .... :.A
0010: 00 00 00 00 00 00 00 00 ........
0018: 00 00 00 00 00 00 00 00 ........
0020: 00 00 00 00 00 00 00 00 ........
0028: 10 00 00 c0 ...A

Might be an network setting error, but I can't tell.
Any other application works fine over network.
I wonder if there's any influence of SQL Server Express...




Re: Windows Communication Foundation (Indigo) sample service doesn't work on Windows XP 64

msdobrescu

Do you see any wrong setting here

>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : usc
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.109.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::250:56ff:fec0:8%4
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3
fec0:0:0:ffff::2%3
fec0:0:0:ffff::3%3

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
1
Physical Address. . . . . . . . . : 00-50-56-C0-00-01
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.153.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IP Address. . . . . . . . . . . . : fe80::250:56ff:fec0:1%5
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168/8111 PCI-E Gigabit Ethern
et NIC
Physical Address. . . . . . . . . : 00-18-F3-08-08-C3
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.58.217
Subnet Mask . . . . . . . . . . . : 255.255.0.0
IP Address. . . . . . . . . . . . : 2002:567a:b15b:5:f0bd:fcc8:795a:ff2e
IP Address. . . . . . . . . . . . : 2002:567a:b15b:5:218:f3ff:fe08:8c3
IP Address. . . . . . . . . . . . : fec0::5:218:f3ff:fe08:8c3%1
IP Address. . . . . . . . . . . . : 2002:54e8:851e:4:f0bd:fcc8:795a:ff2e
IP Address. . . . . . . . . . . . : 2002:54e8:851e:4:218:f3ff:fe08:8c3
IP Address. . . . . . . . . . . . : fec0::4:218:f3ff:fe08:8c3%1
IP Address. . . . . . . . . . . . : fe80::218:f3ff:fe08:8c3%6
Default Gateway . . . . . . . . . : fe80::2a0:c9ff:feee:b5f9%6
fe80::216:17ff:fe7e:9d48%6
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1

PPP adapter RDS:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 82.78.240.60
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 82.78.240.60
DNS Servers . . . . . . . . . . . : 62.231.76.49
81.18.85.7
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 80-00-FB-CF-AD-B1-0F-C3
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::ffff:ffff:fffd%7
Default Gateway . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 52-4E-F0-3C
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:82.78.240.60%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : C0-A8-6D-01
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.109.1%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%3
fec0:0:0:ffff::2%3
fec0:0:0:ffff::3%3
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : C0-A8-99-01
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:192.168.153.1%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : A9-FE-3A-D9
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : fe80::5efe:169.254.58.217%2
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled