Rodcet

From what I noticed so far,

  • A lot of third party gadgets are tossing m_iframe javascript errors.
  • It seems like third party gadgets if set to transparency no longer inherit spaces background color. It seems like they changed all gadgets to have an innate white back ground and transparency settings make everything white and no longer colored to the users selected schema.
  • Live.Com - you can't view any gadgets or add any gadgets.
  • The Api's for adding development mode for gadgets are not working, Existing gadgets in development mode you added via API's still appear to be working. But with the first two issues.
  • I browsed a lot of spaces and it's pretty much across the board - Ton's of Javascipt errors on peoples sites.

This was information as of last night. I didn't test things out today.



Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

mmsingh

I noticed that today I couldn't add a gadget from the gallery to the Live.com site.

Any idea when these issues will be corrected

Thanks





Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

Rodcet

Playing around a little more today..

I actually seen gadgets switch there loading containers. The javascript errors are not occurring on my work PC... When I get home I'll check it again.. Different OS different Development tools installed.

2003 Server SP2 = Javascript Errors
XP Pro = No Javascript errors (but all the other conditions still happen)

The Resize method doesn't appear to work in IE7... It works fine in IE6






Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

Ithael

I'm noticing these issues as well, the new mystery white layer being the most apparent. As an aside: the white layer appears to be between the main gadget div element (the parent namespace in the CSS file) and the document.body; if you set those to distinct colors you'll notice the gadget div nested inside a white layer which is, in turn, nested within the body (each displaying ~20px padding-bottom by default, apparently).

Also, I've seen a number of gadgets which still support transparency; I'm unclear what the variable is. It may be, as you said, a matter of first vs. third party.

Hoping to find a solution soon. Seems like this will need to wait for a fix from the Live.com team.





Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

Ben Walters - MSFT

Regarding the Spaces issues, we are working to resolve the problems identified here, and we will make fixes available soon. We will post a message to the forums after the fixes are rolled out. Thanks for your patience!





Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

Chris Butler - MSFT

Hi everyone.

The issue of not being able to add items from Windows Live Gallery to Live.com should be resolved now. It was a temporary operational issue.

If you see any other issues feel free to send me mail (chrisbu at microsoft.com).

Thanks!






Re: Web Gadget Development Lot's of things broken ... After the Spaces Update.

Ben Walters - MSFT

Chiming in from the Spaces side: we've released an update that fixes the issues listed above by Rodcet. If you run into any new issues with gadgets hosted on Spaces, please let me know.

Thanks!