Living Sword

I tried to change just the images of a gadget. But with the new png, the gadget won't load. The filenames are the same. Although, theres a small difference in their sizes , for example : the original flyout.png image was 303x225 and the new png made by me is 303x226. Could it be because of this small difference also, i haven't made the new images transparent, could that be a reason too

Regards,




Re: Sidebar Gadget Development Any specifics for the png images ?

Andy E

It shouldn't matter, but that doesn't mean that it isn't affecting it (could be a bug, for instance - MS's png rendering isn't perfect). However, if it's a flyout background image (flyout.png ), then it shouldn't affect the main gadget window at all.

Try restarting Sidebar and see if it works then. If not, is it possible you've accidentally altered something else by accident Try implementing some error catching in your code, or switch script debugging on in Internet Explorer's advanced options and restart your gadget.






Re: Sidebar Gadget Development Any specifics for the png images ?

Living Sword

tried restarting Sidebar after installing the gadget..no go. it doesn't show up even in the list of running gadgets.

Andy E wrote:

It shouldn't matter, but that doesn't mean that it isn't affecting it (could be a bug, for instance - MS's png rendering isn't perfect). However, if it's a flyout background image (flyout.png ), then it shouldn't affect the main gadget window at all.



Theres the same small difference of size in the main window(docked.png) that I made. The original image was 130x210 and the new one by me is 130x209. could that be a problem

Andy E wrote:

is it possible you've accidentally altered something else by accident Try implementing some error catching in your code, or switch script debugging on in Internet Explorer's advanced options and restart your gadget.



just replaced the images. did not touch the code.


thanks for the reply.





Re: Sidebar Gadget Development Any specifics for the png images ?

Andy E

Have you tried using images of the original size again As I said, it shouldn't matter at all. Are you using a g:background tag or just setting the gadget background through CSS If you are using g:background, make sure your dimensions are set properly. If you are using CSS to set the body background, switch to g:background.


If all else fails remove the reference to the png image from the gadget's source code completely and see if your gadget fires up then.






Re: Sidebar Gadget Development Any specifics for the png images ?

sted555

Recently I worked on a gadget and faced similar kind of problem.

My original image size was 21kb but after playing around it became 3kb. When I used the 3kb image as the background, the gadget was not showing up. After couple of hours, I realized it may be due to the image and used the 21kb instead. The gadget worked well.

I am able to reproduce this bug. FYI: I used css to set the background.