Trracer

Hello,

I've a problem running emulator (v2) : I cannot access to the local webserver on the host computer !

I want to test some functions using Xml-Rpc on the PocketPc, emulator and webserver (Apache 2) run on the same computer (vista professional). I can navigate to any web sites (on the internet or local network - tried with PocketPc IE) but local webserver is always not found.

Any suggestions to correct this problem

Thanks



Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Mohit Gogia

Hope this helps http://blogs.msdn.com/mohitgog/archive/2006/04/20/579641.aspx

-Thanks,

Mohit





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Trracer

Thanks for your answer.
I don't use Webservice option in Visual Studio as the server side is in php using xml-rpc to communicate.

To give you a example to illustrate the problem : my pc ip address is 192.168.1.235, the pocket PC emulator use dhcp and have a valid ip (192.168.1.23).
When I try to contact a server (private or public) there is no problem. For example my xmlrpc function run fine when I use the ip of my second dev pc (192.168.1.230). But when I try to contact the pc witch run the PPC emulator (192.168.1.235) the host could no be found...

I tried to deactivate the firewall but the problem remain the same (the predefine rule for www seems to be broken, when I tried to activate it I received a message that indicate a rule name cannot start or end by a space...)





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Mohit Gogia

Sorry i am not a web technology or networking expert. I'll suggest to post this question to ASP.NET Web Services and XML Serialization forum http://forums.microsoft.com/MSDN/ShowForum.aspx ForumID=46&SiteID=1 where some expert can help you figure out the issue.

-Thanks,

Mohit





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Trracer

I think this is not a problem of xml or other thing like that, it's just that the emulator refuse to communicate with the host. The problem appears with Internet Explorer for instance, not only XmlRpc api.

Host computer can ping the emulator and access to the embedded webserver, but I'm unable to do the reverse. The emulator is unable to find the host ip address.

It's very strange. I'd searched the forum and KB but not found any message on this kind of problem. Maybe it's a restriction of the emulator, or simply a bug... I'll try to test under Windows 2000 if the same problem occurs...





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Trracer

So, I tried under Windows 2000, and no problem to access the local webserver (using Pocket IE).

The problem should be due to Windows Vista...





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

Eagle117

With the WM5 emulator images I've had to go in and configure it to use the "Work" connection to connect to the Internet and then I am able to access my computer or the Internet from the emulator.



Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

goranco

I'm having the exact same problem here. I'm developing Mobile Web application with Visual Studio 2005 and hosting it on IIS 5.1 When I try to access the web app through Pocket PC 2003 emulator IE the message I get is "The Requested URL was not found".

And with the Emulator IE I can access any Internet page I want. So far I tried to shut down the firewall on my computer, I tried everything with the settings on the emulator and in Activesync and nothing works.

Just to mention, IIS is working fine and I can see my hosted pages in my IE on my computer...

Any suggestions will be welcomed...

thanks in advance...





Re: Device Emulator General PocketPC 2003 Emulator and local webserver access failed

WoayChee

hi, please download the document from here, hope it able to solve your problem.