mohasad

hi ,
i have installed the windows mobile stand alone emulator . i started the emulater in command prompt by following way :
C:/> Device Emulator smartphone.nb0 /skin Smartphone.xml .
the emulator started and everything is fine . but when we click the left softkeys , it s navigating to contacts . the start menu is not opening .
so anyone give the details , in order to make the emulator work . i am not having visual studio 2005 .. i am having only active sync ..
thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

It looked you have rolled your custom image. Can you please share

1. Skin XML file.

2. WM version you are using.

-Thanks,

Mohit





Re: Device Emulator General regarding the stand alone emulator

mohasad

hi ,
i am using the standalone device emulator version 1.0 for windows mobile 5.0.
i have the skin file as follows :
< xml version="1.0" encoding="UTF-8" >
- <skin>
- <view titleBar="Smartphone - WM 5.0" displayPosX="32" displayPosY="50" displayWidth="176" displayHeight="220" displayDepth="16" mappingImage="smartphone_emulator_mask.png" normalImage="smartphone_emulator_up.png" downImage="smartphone_emulator_down.png">
<button toolTip="Power" onPressAndHold="0x75" mappingColor="0xFB10F8" />
<button toolTip="Record" onPressAndHold="0x44" mappingColor="0x8E3BFF" />
<button toolTip="Volume Up" onPressAndHold="0x40" mappingColor="0x80B9BB" />
<button toolTip="Volume Down" onPressAndHold="0x41" mappingColor="0x8AB9BB" />
<button toolTip="Soft Key 1" onPressAndHold="0x3B" mappingColor="0xF699F5" KeyEvent="F1" Comment="Not handled when menu is present." />
<button toolTip="Soft Key 2" onPressAndHold="0x3C" mappingColor="0x5CF443" KeyEvent="F2" Comment="Not handled when menu is present." />
<button toolTip="Talk" onPressAndHold="0x3D" mappingColor="0x11B997" />
<button toolTip="End" onPressAndHold="0x3E" mappingColor="0x487710" />
<button toolTip="Up" onPressAndHold="0x48" mappingColor="0xF79406" KeyEvent="Up" />
<button toolTip="Down" onPressAndHold="0x50" mappingColor="0x323DC6" KeyEvent="Down" />
<button toolTip="Left" onPressAndHold="0x4B" mappingColor="0x3BF8FF" KeyEvent="Left" />
<button toolTip="Right" onPressAndHold="0x4D" mappingColor="0x06AAF7" KeyEvent="Right" />
<button toolTip="Enter" onPressAndHold="0x1C" mappingColor="0xFFF601" KeyEvent="Return" />
<button toolTip="Back" onPressAndHold="0x01" mappingColor="0xB1AC20" />
<button toolTip="Home" onPressAndHold="0x5B" mappingColor="0xDC2C1E" />
<button toolTip="1" onPressAndHold="0x02" mappingColor="0x823214" KeyEvent="D1" />
<button toolTip="2" onPressAndHold="0x03" mappingColor="0x64280A" KeyEvent="D2" />
<button toolTip="3" onPressAndHold="0x04" mappingColor="0x5A1E05" KeyEvent="D3" />
<button toolTip="4" onPressAndHold="0x05" mappingColor="0xF0B478" KeyEvent="D4" />
<button toolTip="5" onPressAndHold="0x06" mappingColor="0xE6A050" KeyEvent="D5" />
<button toolTip="6" onPressAndHold="0x07" mappingColor="0xDC8C32" KeyEvent="D6" />
<button toolTip="7" onPressAndHold="0x08" mappingColor="0xA0A064" KeyEvent="D7" />
<button toolTip="8" onPressAndHold="0x09" mappingColor="0x969632" KeyEvent="D8" />
<button toolTip="9" onPressAndHold="0x0A" mappingColor="0x8C8C28" KeyEvent="D9" />
<button toolTip="*" onPressAndHold="0x42" mappingColor="0x786464" KeyEvent="F8" />
<button toolTip="0" onPressAndHold="0x0B" mappingColor="0x6E5A5A" KeyEvent="D0" />
<button toolTip="#" onPressAndHold="0x43" mappingColor="0x645050" KeyEvent="F9" />
</view>
</skin>






Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

I would recommend you to use Device Emulator v2 which has better funckey support and will automatically try to detect correct funckey. For this try passing /funckey 192 which should work.



Re: Device Emulator General regarding the stand alone emulator

mohasad

what do u mean by passing /function key 192 . can u make it bit clear .
thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator

mohasad

hi Mohit,
what do you mean by passing /function key 192 . can u make it clear . moreover for V2 , the system requirement is Windows vista , i am using only windows xp .
thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

No V2 supports winXP also. It supports all OS Visual Studio 2005 supports.

By passing /funckey i meant option on the command-line. For more details on funckey look into device emulator documentation.

-Thanks,

Mohit





Re: Device Emulator General regarding the stand alone emulator

mohasad

hi mohit ,
i have passed /funckey 192 , still the softkeys are not working . the command that i have used as follows :
i have installed the Emulator in F: directory
"F:\Program Files\Microsoft Device Emulator\1.0\DeviceEmulator.exe" "F:\Program Files\Microsoft Windows Mobile 5.0 MSFP Emulator Images\smartphone.nb0" /skin "F:\Program Files\Microsoft Windows Mobile 5.0 MSFP Emulator Images\SmartPhone.xml" /p /memsize 256 /s F:\Smartphone\wm5.dess \funckey 192 .
can u short out the problem.
thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator


Re: Device Emulator General regarding the stand alone emulator

mohasad

hi mohit ,
still it showing the same problem .the soft keys are not working .
thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

Sorry but i have run out of options. Since you are rolling your custom image so you will have to debug through keyboard driver to see what's happening there.

If you are not using custom image, please give me location for the same so that i can try a local repro to investigate.

-Thanks,

Mohit





Re: Device Emulator General regarding the stand alone emulator

mohasad

mohit ,
actually i am not using custom images . i have downloaded the emulator . and i have started the emulator through command line .could you please download and check it .
actually i had given the following format of command ,
DeviceEmulator .nb0file skinfile .

thanks
sadiq








Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

Sorry for the confusion. But by custom image, i mean did you rolled up Windows Mobile image yourself If not, are you using any microsoft supplied SDK - then please share the link where from you downloaded that SDK



Re: Device Emulator General regarding the stand alone emulator

mohasad

hi mohit,
sorry for not been clear . i am using images only from the specified link from which we download the device emulator 1.0 . if possible can you try the device emulator2.0 from the link that u specified before . so that u can get a clear idea about problems on soft keys .

thanks
sadiq





Re: Device Emulator General regarding the stand alone emulator

Mohit Gogia

Ok. Can you please give me link to path where from you downloaded images I'll download and try them on local m/c.

-Thanks,

Mohit