Brendan C.

Visual Studio gives me an error that reads "Interface not registered" when I try to start debugging a WM 5 PPC project. The same project works for other people. I reinstalled Visual Studio 2005, SP1, the SDKs, and device emulator 2.0. It didn't make a difference. I have used the device emulator 2.0 CTP in the past. Any ideas



Re: Device Emulator General cannot launch emulator from VS 05

Brendan C.

Correction, I get the error when I click the "connect to device" button in the Device toolbar. When I try to start debugging the debugger does not start, and no error is reported, it just waits forever for the emulator to start.





Re: Device Emulator General cannot launch emulator from VS 05

Hammadi Dali


Hi
I hope that in this discussion you will find the solution for your problem

Regards
Hammadi






Re: Device Emulator General cannot launch emulator from VS 05

Brendan C.

I'm not using .NET, so I don't see how the .NET build engine would apply. I can't even connect to the device from Visual Studio, so building, deploying, etc. are not a factor.

Seems like every 2nd or 3rd attempt to connect will cause Visual Studio to crash:

Faulting application devenv.exe, version 8.0.50727.762, stamp 45716759, faulting module ntdll.dll, version 5.1.2600.2180, stamp 411096b4, debug 0, fault address 0x00011f6c.

There's nothing else interesting in the event viewer.

I've tried many permutations of registering and unregistering the different emulators (v1, v2, and v2 CTP) to no avail. I also re-ran the v1 vs_emulator.exe setup. No change.





Re: Device Emulator General cannot launch emulator from VS 05

MAYUR_WAKADE TENDULKAR_23d722

Hi,

Lets try to solve this issue step by step. First, invoke the Device Emulator separately. You can go to C:\Program Files\Microsoft Device Emulator\1.0 or at the installed location. If the emulator work perfect even without VS, then there is issue related with VS and Emulator integration. Else, you can try installing just the emulator or its latest version.






Re: Device Emulator General cannot launch emulator from VS 05

Brendan C.

The emulator works fine when launched from the emulator manager. It is a Visual Studio/Emulator integration issue. What now




Re: Device Emulator General cannot launch emulator from VS 05

Brendan C.

Is there a log that will have more info in it, like which interface is not registered