kzu

I'm getting this error everytime I try to deploy/debug a device project.
I have installed device emulator 2.0 beta, and it used to work just fine.

Any ideas on what could be the cause



Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Idana

Even I am getting the same message while trying to build our new project over my box. Abslutely no idea what to do about it.





Re: Smart Devices General Error: The operation could not be completed. Unspecified error

John Abraham

could be that your project settings, -> configuration settings -> project contexts;; has got the "build" checkbox, unchecked



Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Olunia

I once had the same problem, the solution compiled well and worked on the desktop, but couldn't be deployed. After a hard work I had found that one reference of one of the project has lost. I didn't get any specific error about that.

I just added the refernce and everything started to work well.






Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Simón Medrano

I'm having this same problem right now.
My Build Output reads:


Build succeeded.


Time Elapsed 00:01:05.17

------ Deploy started: Project: xxxxxxxx, Configuration: Debug Any CPU ------

Error: The operation could not be completed. Unspecified error

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

========== Deploy: 0 succeeded, 0 failed, 0 skipped ==========


The .exe file is being generated correctly, and it works ok if I copy it manually to the device. I can then "Start Debugging" (F5) and it builds my project again. Then it throws the same message at the output, and a MessageBox that notifies me of the deployment error, and asks if I want to continue. If I go that way, I can debug the previously manually-copied version (that happens to be just the same).

But after I have made changes to my code, if I want to debug my application again, I have to reapeat the "Build and fail to deploy" + "Manual Copy" + "Build and fail to deploy" + "Debug previously copied" steps every time.





Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Odiug

I hate "me too" postings, but I get the same error...
I tried:
  • different smartphones
  • different versions of ActiveSync
  • different installations of VS2005
  • different host machines
It is a bit frustrating not to get more information on the underlying problem. Are there any log files I am not aware of I looked at the following ActiveSync log files in %USERPROFILE%\Local Settings\Temp:
  • WCESLog.log
  • WCESCOMM.LOG
  • WCESMgr.log
But there is no log message nor error at the moment when the deploy fails. So I guess it fails before engaging ActiveSync.

Also the %USERPROFILE%\Application Data\Microsoft\Visual Studio\8.0\ActivityLog.xml does not provide any helpful information.

Are there any log files or similar debugging sources I am missing

Bye
Guido





Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Russell Davis

I've been running into this same problem. After a lot of fruitless searching, I finally stumbled across the the cause. In my project properties, under the Authenticode Signing section, Authenticode Signature was set to "No", but Provision Device was set to "Privileged Certificate Store". I changed Provision Device to "No" and the error went away. Hopefully this will solve the problem for others as well.

-Russell





Re: Smart Devices General Error: The operation could not be completed. Unspecified error

Russell Davis

Follow up - it was actually the Certificate property that was the problem - it was set to an invalid value. And, somehow I missed this KB article which explains everything:

http://support.microsoft.com/kb/922324