Philip Wagenaar -

I get the following error on this line of code:

<script language="Javascript" src="<%=ResolveUrl("~/")%>Scripts/searchPanel.js"></script>

VS.NET 2003 gives the following error when I try to swtich to design mode view.

Could not open in Design view. Quote Values differently inside a '<%... "value" ...%>' block

I foudn the following page explaing the error and a fix, but I still cannot get it work. http://www.mredkj.com/vbnet/OpenDesignError.html

Kind regards,

Philip



Re: Visual C# IDE Could not open in Design view. Quote Values differently inside a '<%... "value" ...%>' block

decyclone

Hi Philip,

The solution tells you to change th code to :

<script language="Javascript" src='<%=ResolveUrl("~/")%>Scripts/searchPanel.js'></script>

here, I changed src="..." to src='...'.





Re: Visual C# IDE Could not open in Design view. Quote Values differently inside a '<%... "value" ...%>' block

Philip1980

decyclone wrote:
Hi Philip,

The solution tells you to change th code to :

<script language="Javascript" src='<%=ResolveUrl("~/")%>Scripts/searchPanel.js'></script>

here, I changed src="..." to src='...'.

I already tried this, still same error.





Re: Visual C# IDE Could not open in Design view. Quote Values differently inside a '<%... "value" ...%>' block

decyclone

try following :

<%="<script language=\"Javascript\" src='" + ResolveUrl("~/") + "Scripts/searchPanel.js'></script>"%>




Re: Visual C# IDE Could not open in Design view. Quote Values differently inside a '<%... "value" ...%>' block

Philip1980

decyclone wrote:
try following :

<%="<script language=\"Javascript\" src='" + ResolveUrl("~/") + "Scripts/searchPanel.js'></script>"%>

Argh.. I had another "<%..."%> I didn't see before.

Thanks though!