PavanGayakwad

How to make VS 2005 IDE understand dotnet 3.0 framework When I try to install any of extentions is shows below error.

"Set has detected that a pre-requisite is missing. To use Visual Studio 2005 Extensions for .Net Framework 3.0, you must have the .Net framework 3.0 runtime installed" - whereas I have dotnet 3.0 runtime installed on my machine.

Please let me know if any knows how to fix it. Thanks.




Re: Visual C# IDE How to make VS 2005 IDE understand dotnet 3.0 framework?

Figo Fei - MSFT

Hi,

What is your windows and VS 2005 version

The steps should be first install the sp1 for Visual Studio 2005 and then .NET Framework 3.0 after that Visual Studio 2005 extensions for .NET Framework 3.0.

For your information: visual studio 2008 beta2 (with .NET framework 3.5) has released: http://msdn2.microsoft.com/zh-cn/vstudio/aa700831.aspx

Thanks






Re: Visual C# IDE How to make VS 2005 IDE understand dotnet 3.0 framework?

PavanGY

Thanks for responding.
I am using Windows XP with SP2 operating system and SP1 for VS 2005 is already installed. When I try running WCF extension, it is still showing me the same error.

DotNet 3.0 runtime package is downloaded from here http://www.microsoft.com/downloads/details.aspx FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043&DisplayLang=en

- Pavan






Re: Visual C# IDE How to make VS 2005 IDE understand dotnet 3.0 framework?

Figo Fei - MSFT

Hi Pavan,

Can you see the .NET Framework 3.0 in your Current installed programs

Anyway, try download and install .NET Framework 3.0 through this link: http://go.microsoft.com/fwlink/ LinkId=70848

(http://download.microsoft.com/download/3/F/0/3F0A922C-F239-4B9B-9CB0-DF53621C57D9/dotnetfx3.exe)

To see whether it helps.

Thanks






Re: Visual C# IDE How to make VS 2005 IDE understand dotnet 3.0 framework?

PavanGayakwad

Yes, the new dotnetfx3.exe (link given above by Figo Fei) setup gets integrated with VS 2005 IDE well.
I noticed, the version of my existing dotnetfx3 is 3.0.4324.17 and the dotnetfx3 from above link has version 3.0.4506.30.

Now, I am able install extensions.

Thanks a lot
Figo Fei